JIRA Does Not Start due to Index Lock File(s)
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
JIRA will not start. Additionally, you will find an error similar to the following in the logs:
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2010-10-07 10:48:22,789 ERROR [atlassian.jira.upgrade.ConsistencyCheckImpl]
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Index lock file(s) found. This occurs either because JIRA was not cleanly shutdown
or because there is another instance of this JIRA installation currently running.
Please ensure that no other instance of this JIRA installation is running
and then remove the following lock file(s) and restart JIRA:
/app/jira/atlassian-jira-3.13.5-standalone/temp/lucene-90906deb6b27ad5e03a15a2bea317937-commit.lock
Once restarted you will need to reindex your data to ensure that indexes are up to date.
Do NOT delete the lock file(s) if there is another JIRA running with the same index directory
instead cleanly shutdown the other instance.
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Cause
This occurs either because JIRA was not cleanly shutdown or because there is another instance of this JIRA installation currently running.
Resolution
Ensure no instance of JIRA is running.
Delete the mentioned .lock files. See the error message for the location of the lock file, or refer to How do I unlock my JIRA home directory?
Start JIRA.
Re-index to ensure indexes are up to date. See Search Indexing.
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