JIRA does not reflect changes to my Active Directory

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

  1. JIRA out of sync with Active Directory

  2. Recent changes to Active Directory do not appear in JIRA

Diagnosis

Use an LDAP browser (such as Softerra's LDAP Administrator) to review the consistency of your AD controllers. If the domain controller attached to your JIRA or Crowd has a different user list than the Global Domain Controller (GDC), you are having this issue.

Cause

This issue is caused by retrieving the directory listing from a machine other than the Global Domain Controller (GDC). While the GDC is the authoritative directory, other Domain Controller's (DCs) on the network will only synchronize directories periodically. This causes the appearance of an incomplete directory in JIRA.

Solution

Workaround

To work around this issue, increase the sync frequency of your Domain. This does introduce some additional network overhead.

Resolution

To resolve this issue, connect your JIRA or Crowd directly to the GDC

Updated on April 8, 2025

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