Jira Data Center: Resolve Blank Reports Page in Project Settings

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading to Jira Data Center 10.3.0 or later, the Reports page of a Project shows a blank white area.

Environment

Any Jira Data Center upgrading to version 10.3.0 or later

Diagnosis

  1. Upgrade Jira to 10.3.x.

  2. Navigate to a Project's Project Settings page.

  3. On your browser, open a debug session and observe the specific line for Y.previousTheme

    Y.previousTheme = document.querySelector("html").dataset.theme.includes("original") ? "original" : document.querySelector("html").dataset.colorMode,
  4. Click on Reports.

We expect the page to load the different possible reports, such as the Burndown Chart, etc.

The side and top menu bars load, but the area for the available reports is blank. In the browser debug session, we see an error loading the line for Y.previousTheme.

Cause

In Jira 10.3.0, we introduce the Dark Theme as an official option in Jira. However, there is no known cause at this time for this behaviour.

Solution

Navigate to Jira dark features and enable the flag:

com.atlassian.jira.theme.switcher.enabled

The change will be immediate on reload of the page. There is no restart needed.

Updated on May 26, 2025

Still need help?

The Atlassian Community is here for you.