Jira Data Center - Project admins are unable to see advanced coverage audit logs in Project Audit Logs section

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Even though from Data Center v8.8 onwards, some of the Audit Logs were made available for Project Administrators, there are still End user activities that are Issue Related (Category: Issues) that don't show up in the Project Audit logs.

For example, even with Advanced Coverage level for End User Activity, Audit events such as Issue deleted are not visible in the Project Audit logs:

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Environment

Jira Data Center v8.8.x and above

Diagnosis

With Advanced coverage enabled - if a user deletes an issue, the event is only visible for the System Administrators in the Global Audit logs✔️

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These events are not visible in the Project Audit logs

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Cause

The main reasons behind this design decision are:

  • Issue Security Scheme can be configured only by Global Administrators.

Project Administrators have access to the Project Audit Log, but not to all issues. This makes the Audit Log the source of the information leak to Project Administrators.

Solution

Workaround

Updated on April 2, 2025

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