Fix Jira Dashboard gadget failing to load with 'filter could not be retrieved' error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The Filter Results gadget on the Jira dashboard may fail to load and throw the error :

The filter configured for this gadget could not be retrieved. Please verify it is still valid on the issue navigator.

Environment

  • Jira Software on Data Center.

Diagnosis

Upon clicking on the Issue navigator link on the error message, we can see he below error thrown :

The requested filter doesn't exist or is private.

Cause

This behaviour is observed when the Underlying Filter which is used by the 'Filter Results gadget' is

  • Deleted

  • The permissions for this filter have changed.

Solution

  • If the filter was deleted, then please re-create the filter, edit the Filter Results gadget on the Dashboard and add the filter again.

  • If the permissions for the underlying Filter were changed, please reach out to the owner of this filter to rectify this.

Updated on March 21, 2025

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