Jira Cloud Migration Assistant returns a blank screen after its update due to an issue with Analytics Client Plugin
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Issue reported when updating from JCMA 1.7.7 to 1.9.9 so far.
Problem
Updating Jira Cloud Migration Assistant might disable Analytics Client Plugin somehow and prevent users from using this tool as it will only return a blank screen without further details.
Diagnosis
On the front-end, the request below will fail when trying to access JCMA's home page:
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GET https://example.com/rest/migration/latest/dark-features
That will return the error below:
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{
"message": "service matching filter=[(objectClass=com.atlassian.analytics.api.services.AnalyticsConfigService)] unavailable",
"status-code": 500,
"stack-trace": "org.eclipse.gemini.blueprint.service.ServiceUnavailableException: service matching filter=[(objectClass=com.atlassian.analytics.api.services.AnalyticsConfigService)] unavailable
}
You can also confirm this issue by accessing your atlassian-jira.log files and searching for an error like the one below:
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2023-08-01 00:13:52,102-0400 Caesium-1-1 ERROR jiraadmin [c.a.scheduler.core.JobLauncher] Scheduled job with ID 'jira-migration-analytics-events-dispatcher-job-id' failed org.eclipse.gemini.blueprint.service.ServiceUnavailableException: service matching filter=[(objectClass=com.atlassian.analytics.api.services.AnalyticsConfigService)] unavailable
You can confirm AnalyticsClient Plugin is currently disabled by following the steps below:
Go to your Manage apps page
Change the filter to show all apps
Find the Analytics Client Plugin plugin
Expand it and check its status
Jira also logs the plugin state when starting up in the atlassian-jira.log files, the log entry will look like the one blow:
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Analytics Client Plugin : com.atlassian.analytics.analytics-client
Version : 6.1.16
Status : disabled
Vendor : Atlassian
Description :
Resolution
If Analytics Client Plugin services are disabled, you can just enable it by following the steps below:
Go to your Manage apps page
Change the filter to show all apps
Find the Analytics Client Plugin plugin
Expand it and make sure it's enabled
Restart Jira
That should fix the blank screen issue on JCMA.
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