Jira Backup Fails with Illegal Pattern Character Error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The JIRA XML backup fails with the error "Illegal pattern character" and the following appears in the atlassian-jira.log:

1 2 3 4 5 6 7 8 9 10 11 12 13 ERROR ServiceRunner Backup Service [service.services.export.ExportService] An exception while running the export service "Backup Service": Illegal pattern character '<>' java.lang.IllegalArgumentException: Illegal pattern character 'o' at java.text.SimpleDateFormat.compile(SimpleDateFormat.java:769) at java.text.SimpleDateFormat.initialize(SimpleDateFormat.java:576) at java.text.SimpleDateFormat.<init>(SimpleDateFormat.java:501) at java.text.SimpleDateFormat.<init>(SimpleDateFormat.java:476) at com.atlassian.jira.service.services.export.ExportService.createFileName(ExportService.java:301) at com.atlassian.jira.service.services.export.ExportService.run(ExportService.java:114) at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:61) at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:47) at org.quartz.core.JobRunShell.run(JobRunShell.java:195) at com.atlassian.multitenant.quartz.MultiTenantThreadPool$MultiTenantRunnable.run(MultiTenantThreadPool.java:72) at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)

Cause

This is caused by the wrong format being used in the Automatic Backup Configuration in JIRA services. This format specified here is used for generating the file names.

(Auto-migrated image: description temporarily unavailable)

This is similar to Backup Service is not Working Properly due to Misconfigured Parameter.

Resolution

The Date format need to be corrected in the Backup Service configuration as per the steps given below:

  1. Log in as a user with the JIRA System Administrators global permission.

  2. Select Administration > System > Advanced > Services (tab) to open the Services page, which lists the current services running on this system.

  3. Edit the existing Backupservice which is already administered.

  4. Update the date format to a valid format. This format can be anything that SimpleDateFormat can parse. A good default is 'yyyy-MMM-dd-HHmm', which would generate files named like this: '2007-Mar-05-1322'.

  5. Click 'Update' to save the configuration.

ℹ️ Additionally, as per our Backing Up Data we recommend using native DBMS backup tools instead of the XML backup.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.