JIRA Activity Stream returns One or more activity sources were slow to respond and are not included
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The Activity Stream in JIRA's Dashboard returns a message stating: "One or more activity sources were slow to respond and are not included. You can try again with a longer timeout."

The following will appear in the atlassian-jira.log
:
1
2
2015-03-20 08:14:23,105 http-bio-8080-exec-568 WARN captain.america 494x1459683x4 1f0p2ux 192.168.1.91 /plugins/servlet/streams [atlassian.streams.internal.StreamsCompletionService] Registering failure for stream provider JIRA due to error timeout
2015-03-20 08:12:03,339 http-bio-8080-exec-570 WARN agent.carter 491x1459411x2 1t4h6ww 192.168.1.79 /plugins/servlet/streams [atlassian.streams.internal.StreamsCompletionService] Registering failure for stream provider JIRA due to cancellation (timeout)
Cause
The current Activity Stream Gadget uses a fixed timeout of 10 seconds and this warning is displayed when timeout is reached before the source(s) respond. There is an existing improvement request for better handling of Activity Stream timeouts which is being tracked under STRM-2140 - Activity Stream Times Out with One or more activity sources were slow to respond and are not included.. There are also several bugs that can contribute to these timeouts and upgrading will fix those specific problems:
JRASERVER-37905 - Activity stream in the user profile times out easily on larger instances
JRASERVER-41629 - Activity Stream can timeout for issues with very long histories
Additionally, it is possible for certain Activity Stream providers (Atlassian apps or plugin-specific apps accessible through AppLinks) to be banned from returning results if they consistently time out. That means the stream may return no results at all, and be blank. This bug fix alleviates some impact of that as it will reduce timeouts on the user profiles within JIRA. If a provider is banned, there is not currently any warning of this - the fix to that is tracked in:
STRM-2239 - Activity stream time-out cancellation causes future requests to return blank results
STRM-2264 - Re-enable warning about banned providers in activity stream
Also there is currently no possibility to configure the default timeout for the activity stream, see also JRASERVER-32255 - Configuration for default timeout in activity stream .
Verification
If using multiple sources, identify which one is slow to respond by creating multiple Activity Stream gadgets on a test dashboard and see which ones time out. Otherwise, this can be verified if the above behaviour is experienced.
Workaround
This can be alleviated by using a filter in the Activity Stream to reduce the amount of issues returned. By default, the Activity Stream will query every single issue in JIRA and then order it - for large JIRA instances this will often mean the query will take longer than 10 seconds. Using a filter such as the below will reduce the time spent for this query as it will only return issues from after that date:

ℹ️ Please see our Adding the Activity Stream Gadget documentation for further information on configuring the Activity Stream to use a filter.
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