java.lang.IllegalArgumentException: Input must be in the format 'YYYYMMDD'
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Sometimes an error might appear in Jira on the Issue Navigator or while setting Due Date or during other operations.
The following appears in the atlassian-jira.log
:
1
2
3
4
5
Input must be in the format 'YYYYMMDD'.
java.lang.IllegalArgumentException: Input must be in the format 'YYYYMMDD'.
at com.atlassian.jira.datetime.LocalDateFactory.fromIsoBasicFormat(LocalDateFactory.java:80)
at com.atlassian.jira.util.LuceneUtils.stringToLocalDate(LuceneUtils.java:168)
at com.atlassian.jira.issue.statistics.LocalDateFieldSorter.getValueFromLuceneField(LocalDateFieldSorter.java:31)
Environment
Jira Data Center
Cause
This error is generally caused when the date formats set for Jira conflict the date formats set for Java.
Resolution
Configure the date formats under Advanced Settings of General Configuration in Jira based on the instructions on this page : Configuring JIRA Options
Check the date formats under Look and Feel and see if it's correct.
If date formats of both pages are correct, try to do the following step to clear the cache and rebuild it:
Shutdown your Jira
Remove the following directories as they will rebuild when you restart Jira
jira-home-path/caches/indexes
Restart Jira
Reindex Jira
Was this helpful?