Issues Become Resolved Silently

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When putting an Issue through a Transition (including the Create Issue transition), the Issue becomes resolved, even though a Resolution was not selected.

Diagnosis

Typically, the Issues affected by this problem will all have the same Resolution.

Cause

This is normal program behaviour. The Resolution field is special, in that it is required when it appears on a screen, even though it's not been made required in the Field Configuration. If it appears on a screen, any actions that involve that screen will result in a Resolution being set.

Resolution

  • Locate the offending Transition

  • Identify the Screen used by this transition

  • Ensure the Resolution field does not appear on this screen

Updated on April 8, 2025

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