Issues associated to users deleted from LDAP or crowd can not be reassociated to a different user
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When you try to search for issues created or assigned to a non-existing user, JIRA is not able to return any result as the user no longer exist. Upon navigating to the issue URL directly, the issue is viewable but the assignee or reporter field is deactivated and the user can not be accessed. Operations such as re-assigning or changing the reporter on story points returns with an error:
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com.opensymphony.user.EntityNotFoundException: No user xxxxxx found
at com.opensymphony.user.UserManager.getEntity(UserManager.java:259)
at com.opensymphony.user.UserManager.getUser(UserManager.java:181)
at com.atlassian.core.user.UserUtils.getUser(UserUtils.java:37)
at com.bt.collaborate.storm.edit.EditStory.doUpdateUserFields(EditStory.java:519)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at webwork.util.InjectionUtils$DefaultInjectionImpl.invoke(InjectionUtils.java:70)
at webwork.util.InjectionUtils.invoke(InjectionUtils.java:56)
at webwork.action.ActionSupport.invokeCommand(ActionSupport.java:433)
at webwork.action.ActionSupport.execute(ActionSupport.java:157)
at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:54)
Cause
By default JIRA does not allow the removal of a user that is an Assignee or Reporter of any issue or the Lead of any project. This enforces users to reassign issues before deleting. This is however not the case if the user is from LDAP or crowd. There is a possiblity that the user has been deleted from LDAP/CROWD. Confirm that with your LDAP/CROWD admin.
⚠️ We do not recommend to delete users within JIRA, and suggest to deactivate the user as in that documentation.
Workaround
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
You can try either of the following workarounds:
Recreate back the user in LDAP with same user name and the user will be recreated in JIRA upon synchronization. You can then proceed search and re-assign all issues to someone else before deleting back the user in LDAP.
Another option is to recreate the user directly in the internal directory and perform the issue association once again
ℹ️Please see our Troubleshooting LDAP User Management documentation for further assistance with diagnosing LDAP problems.
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