Issues are not appearing in Board for specific users
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
When an issue is created by a specific user , the issue is successfully created and can be accessed via link but it is not appearing in the Board.
Diagnosis
Diagnostic Steps
Issue Level Security has been configured for that project.
Make sure the project is included in the JQL Filter of the board (see Configuring Filters).
Make sure the user have the Browse Projects and Create Issuespermission.
The problem still persists after performing a Full Reindexing as per Search indexing.
Cause
A customized post function being configured after the re-index post function. Hence, the index is out-of-sync once the issue is created.
Solution
Resolution
Move the customized post function before the re-index post function.
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