IssueHistory() history does not display any recently viewed issues for users who haven't used Jira for a while

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When users login to Jira after an extended period of time (90+ days) of not using Jira, the function does not display any issues that they had worked on before the inactivity period.

Environment

Any Jira Server & Data Center Version

Diagnosis

IssueHistory() JQL function does not display any recently viewed issues for users who haven't used Jira for over 90 days.

Cause

There's a hard coded scheduled job in Jira that runs every day to remove items that are older than 90 days from the issue history. This is an expected behavior.

Updated on April 8, 2025

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