Issue URL links contain undefined for Project Key

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After upgrade Jira, when attempting to access an Issue link, the URL is redirected to replace the project key with the word undefined.

For example, when clicking on issue link for <Jira-BaseURL>/browse/ABC/ABC-13598, you are incorrectly redirected to <Jira-BaseURL>/browse/undefined/ABC-13598.

The image below may be displayed after the redirect:

(Auto-migrated image: description temporarily unavailable)

Cause

This was found to be caused by an unsupported version of third party app, Smart Attachments.

Solution

There are two potential solutions to this:

  • Update Smart Attachments app to the most recent version via Settings > Manage Apps > Manage Apps > Update (on the Smart Attachments app)

  • Uninstall the Smart Attachments app from the Jira instance via Settings > Manage Apps > Manage Apps > ( select Smart Attachments app ) > Uninstall

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.