Issue Type with Name 'Sub-task' Already Exists

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When creating a sub-task, the following error is thrown:

1 2 3 4 5 6 7 ... com.atlassian.jira.exception.CreateException: Issue Type with name 'Sub-task' already exists. at com.atlassian.jira.config.DefaultSubTaskManager.createSubTaskIssueType(DefaultSubTaskManager.java:112) at com.atlassian.jira.config.DefaultSubTaskManager.enableSubTasks(DefaultSubTaskManager.java:83) at com.atlassian.jira.web.action.admin.subtasks.ManageSubTasks.doEnableSubTasks(ManageSubTasks.java:35) ...

Cause

This is caused by a duplicate Issue Type named 'Sub-task'. A default sub-task issue type called 'Sub-task' will be created when the feature is enabled. JIRA does not allow you to have two issue types with the same name.

Resolution

Rename the issue type called 'sub-task, then enable the Sub-tasks feature again.

Updated on April 8, 2025

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