Resolve "Issue Type Invalid" Error in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This article provides solutions to resolve the 'Issue Type Invalid' error in Jira Data Center, including steps for identifying and correcting issue type scheme settings

Symptom

1. In Jira applications, you might see the error message The issue type selected is invalid when trying to move issues.

2. When moving an issue to another project, the project selection may not be correctly displayed. In this case, the below error can be seen in the browser's console:

1 Uncaught TypeError: Cannot read property 'toLowerCase' of undefined

Cause

In Jira, the Default Issue Type Scheme should include all issue types present on the instance. When that's not the case, multiple problems can occur, such as the failure when moving issues.

There are two possible causes for problems related to this.

1. When the target issue type is not included in the Default Issue Type Scheme. You can determine which issue types are missing on that scheme by running the following query on the Jira database;

1 2 3 SELECT id, pname FROM issuetype WHERE id NOT IN (SELECT optionid FROM optionconfiguration WHERE fieldconfig = 10000 AND fieldid = 'issuetype');

2. When Jira somehow reads another Issue Type Scheme as the default, instead of the Default Issue Type Scheme. Run the following query against your database to check if the correct Issue Type Scheme is set as default.

1 2 3 SELECT id FROM configurationcontext WHERE customfield = 'issuetype' and project is null

You should see the ID 10000 returned. If not, follow the workaround below.

Workaround

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

The following SQL commands are specific to PostgreSQL. If you're using a different database, you may need to adjust the commands accordingly. Please consult your database documentation for guidance.

Cause 1

To add missing issue types to the Default Issue Type Scheme:

  1. Shut down Jira

  2. Identify the missing values using the following SQL query

    1 2 3 SELECT id, pname FROM issuetype WHERE id NOT IN (SELECT optionid FROM optionconfiguration WHERE fieldconfig = 10000 AND fieldid = 'issuetype');
  3. Add the missing entries from the previous step using this SQL statement. Repeat the query as many times as necessary until you've added all missing issue types

    1 2 3 INSERT INTO optionconfiguration VALUES ((SELECT MAX(oc.id)+1 FROM optionconfiguration oc), 'issuetype', '<missing_issue_type_id>', 10000, (SELECT MAX(oc.sequence)+1 FROM optionconfiguration oc WHERE oc.fieldconfig=10000));

    ℹ️ Replace <missing_issue_type_id> with the ID of the missing field

  4. Fix the sequence_value_item table to avoid key violations

    1 2 3 UPDATE sequence_value_item SET seq_id = (SELECT MAX(id)+100 FROM optionconfiguration) WHERE seq_name = 'OptionConfiguration'; 
  5. Start Jira

  6. Go to Administration > System > Indexing and click on Lock JIRA and rebuild indexes to perform a full re-index.

Temporary workaround without fixing the DB

Some customers reported that this worked for them:

Search for issue through the issue navigator and use the bulk change to move the issue.

Cause 2

To restore Default Issue Type Scheme as the default scheme

  1. Shut down Jira

  2. Run the below SQL queries in JIRA's database

    1 2 DELETE FROM configurationcontext WHERE id IN (SELECT cc.id FROM configurationcontext cc WHERE cc.customfield = 'issuetype' AND project IS NULL);
    1 2 INSERT INTO configurationcontext VALUES (10000, NULL, NULL, 'issuetype', 10000);
  3. Fix the sequence_value_item table to avoid key violations

    1 2 3 UPDATE sequence_value_item SET seq_id = (SELECT MAX(id)+100 FROM configurationcontext) WHERE seq_name = 'ConfigurationContext';
  4. Start Jira

  5. Go to Administration > System > Indexing and click on Lock JIRA and rebuild indexes to perform a full re-index.

Updated on April 24, 2025

Still need help?

The Atlassian Community is here for you.