Issue Security Level is not added to tickets even though it is added in Post Function.
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Issue Security Level does not get added to tickets during creation even if it is configured using Post Function.
Environment
Jira Service Management Cloud
Diagnosis
Tickets should be created without updating Security Level.
Cause
Set Issue Security Level based on user's Project role was added as the last action in Post Function for Create transition.
Solution
Set Security Level action should be moved to the top of the Post Function before Creates the issue originally.
To Update the Post Function in Create Transition,
Navigate to the affected project.
Select the affected workflow and edit it.
Click on Create transition > Click on Post Function
Move the Post Function that updates the Security Level to the top of the Post Function before Creating the issue originally using the Move Up button.
If the issue is still not resolved, please also review the article How-to update Issue Security levels on new and existing issues, or feel free to contact Atlassian support.
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