Issue export error : 414 Request-URI Too Large

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Error when attempting to export issues 414 Request-URI Too Large

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Diagnosis

When you attempt to export an issue with a complex JQL query via the Atlassian Cloud Jira you may experience error 414 Request-URI TooLarge. This error occurs because the service is yet to authenticate the client requesting the resource and hence they are redirected to /v2/auth/flow. If they try using a simple JQL to begin once and use export it to Excel, it authenticates the client requesting the resource the next time.

Cause

This error occurs because the service is yet to authenticate the client requesting the resource and hence they are redirected to /v2/auth/flow. If they try using a simple JQL to begin once and use export it to Excel, it authenticates the client requesting the resource the next time.

Solution

Try out the following steps to resolve the issue:

  • Login into the site

  • Use a very simple JQL that returns less than 1000 rows for example 

    created> startOfDay(-1) or created> startOfDay()

  • In the next step click Apps -> Open in Microsoft Excel

  • Follow the screen prompts to authenticate and enter the code

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  • Once you enter the code you would be redirected to the following screen

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  • It will download the selected issues.

  • You can now use the original query to export issues and you should no longer experience 414 errors as long as the App is authenticated. 

Note: You can double-check whether the App is authorized by accessing the following URL https://id.atlassian.com/manage-profile/apps

Updated on March 13, 2025

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