Issue collector doesn't add data to created issue
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When using a Jira issue collector, the data entered in the form don't show up in the issue description as expected.
There are no related errors in the logs.
Here's an example of what we'd expect to see using the "Got feedback?" template:

Cause
The description field is not present in the Create issue screen.
Solution
Add the description field to the Create issue screen. Check Configuring a screen's tabs and fields
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