Issue Collector Activity Graph and Statistics do not get updated
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
One of the most interesting features of the Issue Collector plugin is the ability to keep track of how many issues were created through the Issue Collector Plugin. This is represented through an activity graph, whereby it shows a graph for the number of issues created via Issue Collector (Y-axis) on a daily basis (X-axis).
However, upon creating an issue through the issue collector plugin, the statistics do not get updated. The are no activity on the Activity Graph nor there are list of issues on the statistic (even though the issues are created).
Cause
The system field Label is not configured on the Create Issue Screen or it is hidden from the Field Configurations.
All issues that are created by the issue collector will automatically add the label collector-xxx. If the label field is not available during the issue creation, then all those issues do not have the label collector-xxx. The way JIRA counts how many issues are created is by counting the number of issues that have the label collector-xxx.
Resolution
Configure the system field Label on the Create Issue Screen and confirm whether Label is not hidden
Go to Administration > Issues > Screens > Screens (tab), and click on the Configure link specifically for the create issue screen. Please select the screen for that problematic project.
When a new screen appears, scroll down to the bottom of the page, and select the field Labels and Click on the Add button. This will add the label fields on a screen
Also, please make sure the system field Label is not hidden, via Administration > Issues > Fields > Field Configurations (Tab)
Was this helpful?