Invalid Server ID - Please try copying and pasting the Server ID directly from the product
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When trying to get the new licence on my.atlassian.com, it's asking for a Server ID. After pasting the Server ID directly from Jira, it prompts the error "Invalid Server ID - Please try copying and pasting the Server ID directly from the product".

Cause
The Server ID directly copied from Jira is in the old format "9045394c-dfac-4cd7-b335-4465ac1d0665," which is no longer accepted on my.atlassian.com.
Solution
Get a new Server ID in the up-to-date format "B4WM-2344-8T6T-4VDK" by installing a fresh dummy instance. The new Server ID is shown during the install, and there's no need to restore any data:

The dummy instance can be destroyed afterwards. This Server ID in the up-to-date format can be used to retrieve the licence on my.atlassian.com.
Was this helpful?