Invalid date when trying to Log Work in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

When trying to Log Work on an Issue in Jira, the Date Started field shows a invalid date or returns an error when a valid date is entered.

Diagnosis

Check the Date/Time Formats in Jira Configuration:

  • Administration > System > User Interface > Look & Feel > Date/Time Formats

Check the Advanced Settings for Date Picker and Date Format:

  • Administration > System > General Configuration > Advanced Setting.

Cause

Date and Time picker formats are not matching in JIRA's Advanced Settings.

Solution

Resolution

  1. Go to Administration > General Configuration > Advanced Setting.

  2. Verify the key jira.date.picker.java.format corresponds with the key jira.date.picker.javascript.format.

  3. Verify the key jira.date.time.picker.java.format corresponds with the key jira.date.time.picker.javascript.format.

ℹ️ See here for more on Configuring date picker formats

Updated on April 21, 2026

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