Installation Fails Because Schema Name Does Not Exist
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When configuring JIRA with an external database, it fails with this error:
1
2
3
CREATE TABLE jiraschema.workflowschemeentity (ID NUMERIC NOT NULL, SCHEME NUMERIC, WORKFLOW NVARCHAR(255), issuetype NVARCHAR(255),
CONSTRAINT PK_workflowschemeentity PRIMARY KEY (ID))
Error was: java.sql.SQLException: The specified schema name "jiraschema" either does not exist or you do not have permission to use it.
Cause
An invalid database schema name has been specified.
Resolution
JIRA 4.3 or below
Check whether schema name specified in
<jira-install>/atlassian-jira/WEB-INF/classes/entityengine.xml
is valid. If the schema name exists in the database, ensure that database user has permission to use the schema.
JIRA 4.4+
Check the schema specified in <jira-home>/dbconfig.xml.
If the schema name exists in the database, ensure that database user has permission to use the schema.
ℹ️ Check for leading blanks spaces in your schema name as that is known to cause issue. You can quickly identify schemas with a leading white space since they will show at the top of the alphabetized list of schema names.
Was this helpful?