Inline editing does not work for some fields in Jira Data Center
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The option to edit a field "in-line" without having to click the "Edit" button to edit all fields from the issue is unavailable to some fields in the Issue detail view.
Cause
The "In-Line" field edit feature is disabled for fields that are not present in the Screen associated with the Edit IssueOperation config on the Project Configuration for the Screen scheme associated with the Issue-type.
Resolution
Add the fields you wish to edit In-line on the screen associated with the Edit Issue operation in the respective screen scheme associated with the Project and Issue-type:
The easiest way is to access the config from the Project's Admin Configuration panel:
Go to: Project Settings > Screens
Expand the Issue-type you want to modify
Click the screen associated with the "Edit Issue" operation.
Select the fields you want to enable the In-line editing feature.
Click to add
Check if the field is now editable in-line from the Issue details view.
That's it!
Multiple projects using the same scheme?
If the same screen is used for other Projects, issue-types, schemes, etc... and you don't want to modify those fields for them, you can:
Copy the current screen from the Screens on the Administration panel > Issue > Screens
Add the editable fields on the newly copied screen
Associate the newly copied screen with the Project/Issue-type by clicking the edit button on the top-right end of the issue-type config in the project.
In the configuration page, click the Edit Action of the Edit Issue operation
In the last page, select the newly copied screen from the list and Update.
ℹ️ Check more details on this page: Associating a screen with an issue operation
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