Incorrect links on JIRA mail messages when using JangoMail as relay server

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

The links on the JIRA mail messages may point to an invalid URL instead of a JIRA link (such as http://jira.baseurl.com/browse/ABC-123).

Diagnosis

When enabling the Outgoing Mail logs on Administration -> Troubleshooting and Support -> Logging & Profilling, you'll see the content of the mail message being created with valid links on atlassian-jira-outgoing-mail.log. However, the same links will be modified when the message is delivered into your mail client.

Cause

Since the mail message is being generated correctly in JIRA, this is a misconfiguration on JangoMail. It has a feature called Click Tracking which is enabled by default, and it does modify the JIRA links into the mail content.

Solution

Resolution

  • In JangoMail, click in Settings -> expand the Tracking session -> General Option.

  • Unmark all the checkboxes on it:

    • Activate Open Tracking;

    • Activate Click Tracking;

    • Exclude Text.

ℹ️ In case of any doubt in performing the steps above, please contact the JangoMail support.

Updated on April 2, 2025

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