Incorrect Issue Type Configuration for Custom Fields Stops CSV Import
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
During the import of a CSV file into an existing Project containing Custom Fields, the import process will encounter an error and stop.
The resulting error log reports:
2014-09-23 13:46:18,909 JiraTaskExectionThread-11 ERROR user 826x7970x1 1bl903h 12.124.244.202,10.20.255.254,10.23.62.13 /secure/admin/ImporterLogsPage!import.jspa [imports.importer.impl.AbstractDataImporter$1Thread[http-bio-8080-exec-19,5,main]] Unexpected failure occurred. Importer will stop immediately. Data may be in an unstable state
java.lang.NullPointerException
at com.atlassian.jira.plugins.importer.imports.importer.impl.customfields.CustomFieldsUtil.createOptionIfDoesNotExist(CustomFieldsUtil.java:215)
at com.atlassian.jira.plugins.importer.imports.importer.impl.customfields.CustomFieldsUtil.handleOptionsInHierarchy(CustomFieldsUtil.java:198)
at com.atlassian.jira.plugins.importer.imports.importer.impl.customfields.CustomFieldsUtil.addOptions(CustomFieldsUtil.java:154)
...
Environment
Jira 6.3.6 with Jira Importers Plugin (JIM) version 6.2.3 (likely affects other versions).
Diagnosis
Issues contained in the CSV file utilize custom fields that were already created/configured in JIRA.
Cause
The Custom Fields within Jira do not have Issue Type associations to match the Issues being imported from the CSV file.
Solution
Resolution
Gather data from CSV file
Identify Custom Fields to be imported
Identify Issue Types used per Custom Field
Go to
Administration
>>Issues
>>Custom Fields
For each Custom Field identified:
Find custom field
Click the 'cog' icon for the custom field
Click
Configure
Click
Edit Configuration
Under 'Choose applicable issue types' heading, use the 'Issue Types' selection field to choose appropriate issue types for custom field
Check the 'applicable context' for custom fields on the same screen to ensure your custom field is compatible with your Project(s). 'Global Context' allows the custom field to be used with any Project.
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