Incoming Email Handler encounters "Unable to create issue with message.: null"
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
A configured email handler for incoming messages does not appear to be working (ie - no issues are being created or no comments being added to existing issues).
Messages similar to the following appear in the atlassian-jira.log
:
1
2
3
4
5
2014-09-07 15:01:05,542 atlassian-scheduler-quartz1.clustered_Worker-4 WARN ServiceRunner jira@xxxxx.com Global email replies to JIRA comments [atlassian.mail.incoming.mailfetcherservice] jira@xxxx.com Global email replies to JIRA comments[10700]: Unable to create issue with message.
java.lang.NullPointerException
at com.atlassian.jira.issue.customfields.impl.DateTimeCFType.getDefaultValue(DateTimeCFType.java:151)
at com.atlassian.jira.issue.customfields.impl.DateTimeCFType.getDefaultValue(DateTimeCFType.java:56)
at com.atlassian.jira.issue.fields.CustomFieldImpl.getDefaultValue(CustomFieldImpl.java:1248)
Cause
This is a known issue tracked in JRA-39687.
Resolution
Browse to JIRA Administration > Issues > Custom Fields.
Look for any fields with the Available Context(s) of "Not configured for any context".
Configure them (click on the Cog Icon > Configure).
Edit the configuration.
Select the appropriate context as per Configuring a Custom Field.
Repeat this for all custom fields with the problem "Not configured for any context".
Verify if JIRA is able to create issues from emails.
Was this helpful?