HTTP 504 error returned by Jira Server or Data Center when attempting to delete an issue with many attachments

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When attempting to open an issue with with a large number of attachments in order to delete it, the operation times out with an HTTP 504 error message returned.

Environment

All Jira Server/Data Center environments that have a reverse proxy.

Cause

When the Jira server is processing the load request, if it takes longer than the reverse proxy expects to get a response, the proxy can return a 504 Gateway timeout.

Solution

First validate there are no proxy timeouts that can be increased. Since the proxy is returning the 504 error message to the user, there is likely a timeout within the proxy configuration on how long to wait for a response from the upstream server before returning the 504 error. If there is a timeout that can be increased to allow the load operation to complete, the issue can then be deleted as was originally desired.

If modifying the proxy timeout does not resolve the issue, another potential option is to delete the issue from Jira without opening it. This will prevent the need for Jira to perform the load operation and potentially bypass the long wait time causing the timeout. To delete an issue without opening it:

  • Select Issues > Search for issues.

  • On the right side of the screen change the view to List View if it is not set already.

  • Execute a search that will find this specific issue.

  • Hover over the row for that issue and on the right side of the row there will be a button with three dots. Select that button.

  • Choose Delete from the menu.

Updated on April 8, 2025

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