HTTP 500 error when accessing and or editing Jira filter - write.lock: Input/output error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Error HTTP 500 will be displayed on the UI, related error will be registered on atlassian-jira.log:

1 2 3 4 5 6 2023-02-28 09:29:26,932-0800 http-nio-8080-exec-4 ERROR [c.a.j.web.servlet.InternalServerErrorServlet] {errorId=, interpretedMsg=, cause=com.atlassian.jira.util.RuntimeIOException: java.nio.file.FileSystemException: /var/atlassian/application-data/jira/caches/indexesV1/entities/searchrequest/write.lock: Input/output error, stacktrace=com.atlassian.jira.util.RuntimeIOException: java.nio.file.FileSystemException: /var/atlassian/application-data/jira/caches/indexesV1/entities/searchrequest/write.lock: Input/output error at com.atlassian.jira.index.WriterWrapper$1.get(WriterWrapper.java:88) at com.atlassian.jira.index.WriterWrapper$1.get(WriterWrapper.java:79) at com.atlassian.jira.index.WriterWrapper.<init>(WriterWrapper.java:73) at com.atlassian.jira.index.WriterWrapper.<init>(WriterWrapper.java:79) [...]

Cause

Jira fails to acquire the Index lock, most commonly, this happens when the filesystem has become corrupted, or permissions are incorrect.

Solution

  • Stop your Jira instance (or if Data Center, the affected node)

  • If still present, delete the write.lock file on the path mentioned in the error (you may need to enforce root/administrator permission to do so)

  • Restart the Jira instance

Should you not be able to delete the file with Jira stopped, then verify if the system is able to list it's metadata (ls -la in Linux, dir in Windows). If this fails, or presents inconsistent results (such as "?" instead of file owner), reach out for your infrastructure team to verify possible hardware failure scenarios, then restore a Jira backup.

Updated on April 8, 2025

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