How to upload CSV import file which has failed with 'Invalid file' error in Assets

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Learn why a CSV file upload fails with "Invalid File" error in Assets import.

Diagnosis

While a CSV file is uploaded in the CSV import, the upload fails, and it throws "ERROR Invalid File."

Cause

The file is not correctly formatted

Assets import can't read the file correctly, as the file might be corrupted or not configured properly.

Solution

Check the CSV file for issues

  • Verify the CSV file for any duplicated Column Names that might be causing the issue.

  • Check for any empty columns in the CSV file including the header of the file.

Updated on June 19, 2025

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