How to set "Name" and "Email" as required fields in the Issue Collector

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Based on this improvement request, users may want to set the fields "Name" and "Email" from the Issue Collector as required fields.

Cause

Currently there isn't a possibility to modify these fields in the Issue collector and there isn't a web interface solution to set them as required.

Workaround

To achieve this, you will not be able to set these native fields as required, but you will need to create custom fields and set them as the required ones. To do this (and also to better understand this), follow the steps below:

  1. Follow all of the steps contained in this KB to remove the "Name" and "Email" fields from the issue collector;

  2. Once these are removed, browse through Administration -> Issues -> Fields;

  3. Create a couple of custom fields that will fill your needs for "Name" and "Email" in the issue collector;

  4. Set these new fields as required by clicking on the "Field Configurations" tab and then (after clicking on the field configuration you are using) click on the "Required" option in the right side of the custom field;

  5. Browse to the Issue Collector page (inside the project) and set your Issue collector template as "Custom".

  6. Add the fields you've created as required in the Issue Collector;

Updated on April 11, 2025

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