How to set Attachment field back to not Required

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The attachment field is marked as required in all screens.

Diagnosis

The Attachment field has been marked as Required in the Field Configuration.

ℹ️ By default, the Attachment field does not have option to be set as Required.

Resolution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Run the following SQL query to check in which Field Configuration the Attachment field has been marked as Required :

    1  SELECT fieldlayoutitem.ID, fieldlayout, fieldidentifier, isrequired, name FROM fieldlayoutitem LEFT JOIN fieldlayout ON fieldlayoutitem.fieldlayout = fieldlayout.id WHERE fieldidentifier = 'attachment';

    ℹ️ If the row has isrequired=true , then the field configuration has the Attachment field marked as required.

  2. Backup the JIRA database.

  3. Set the Attachment as Optional by run the SQL update in the JIRA database:

    1 UPDATE fieldlayoutitem SET isrequired='false' WHERE fieldidentifier='attachment';

    ℹ️ This query is to update Attachment field as Optional in all Field Configuration.

  4. Restart JIRA.

Updated on April 8, 2025

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