How to retain created date while importing issues

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

While importing issues via "External System Import" using CSV file, the created date is getting replaced with the date when issue gets imported.

Environment

Jira Cloud

Diagnosis

The created date will be imported as current data only when you don't map created date field or the format of the date and time is different in your CSV.

Cause

The date format is different in CSV from the user interface default value.

Solution

While importing the issues with CSV, there will be a step where you need to select the project. On this same page there is a field for date format.

(Auto-migrated image: description temporarily unavailable)

If you enter correct format of date (same as your CSV) here and map Created field with "Date created" Jira field , Jira will import the issue with correct created date which is mentioned in CSV.

(Auto-migrated image: description temporarily unavailable)

Example: 

If the created date value in your CSV is 22/03/24 15:00 then you need to use the date format as dd/MM/yy hh:mm 

For more information, refer SimpleDateFormat.

Updated on February 13, 2025

Still need help?

The Atlassian Community is here for you.