Retaining Creation Date During Work Item Import in Jira Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When importing work items using a CSV file through "External System Import," the original created date is overwritten by the import date.
Diagnosis
The created date will default to the current date if you don't map the created date field or if the date and time format in your CSV is incorrect.
Cause
The date format in the CSV file does not match the default date format used in the user interface, which may cause import errors.
Solution
While importing work items with CSV, there will be a step where you need to select the project. On this same page, there is a field for date format.
If you enter the correct format of the date (the same as your CSV) here and map the Created field with the "Date created" Jira field, Jira will import the work item with the correct created date mentioned in the CSV.
Example:
If the created date value in your CSV is 22/03/24 15:00 then you need to use the date format as dd/MM/yy hh:mm
For more information, refer SimpleDateFormat.
Was this helpful?