How to rename the default Team custom field from Advanced Roadmaps
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When you install Advanced Roadmaps for Jira or install a Jira Software version greater than 8.15 where it comes bundled, it will automatically create a custom field named Team. This may cause confusion on instances where a pre-existing field with the same name existed since custom fields with duplicate names can return unexpected results when running JQL. Note that the pre-existing field might have been created manually or through the use of a third-party plugin.
Jira uses a specific customfieldtypekey
to determine what field it should use for Advanced Roadmaps for Jira which makes it possible to rename the field.
Environment
The field exists on all version of Advanced Roadmaps for Jira.
Renaming the field should only be done on Jira Software 8.15 and newer since it would cause issues on previous versions per JPOSERVER-2924 (fixed).
Diagnosis
Check the current field available for Advanced Roadmaps for Jira (current name will be on cfname
field):
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select * from customfield WHERE customfieldtypekey = 'com.atlassian.teams:rm-teams-custom-field-team';
Query to check if there are other fields named Team on your instance:
1
select * from customfield WHERE cfname like ('Team%');
Solution
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
All queries were written and tested on PostgreSQL.
Other DB products might need syntax adjustments and your setup might require database name, schema to be provided for table names.
If your database is case-sensitive and any query returns an error related to table not found, please, observe if in the database the queried table name is capitalized or in lower case.
Option 1
To do that, you will have to unlock it since it's a system field followed by updating the name to that of your choosing:
Lock it again afterwards using the steps from the Article.
This route does not require a restart of Jira but you should re-index afterwards.
Option 2
Alternatively if you're comfortable with DB updates you could go this route:
Here we're using "Roadmaps Team" as an example name.
1
UPDATE customfield SET cfname = 'Roadmaps Team' WHERE customfieldtypekey = 'com.atlassian.teams:rm-teams-custom-field-team' and cfname='Team';
❌ This route requires a cold restart to take effect - bring all nodes down followed by starting them one by one so the cache is re-created correctly and you ensure consistency.
A reindex is also needed.
While we've shared these steps with several clients and they running with it successfully, make sure you test it on a testing environment first to rule out any particular behavior specific to your system.
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