How to preserve comment author details when importing issues via CSV?
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
While importing comments through a CSV import, some comments are created with the name of the user who performed CSV import instead of the actual comment author.
1
Commenter named <accountid> not found. Creating issue with currently logged in user instead
Environment
Jira cloud
Cause
When the user is not added to the site, the below error is prompted after migration and the comments are created with author name of the user currently performing the CSV import.

Solution
To resolve the issue, add the comment authors to the site and assign them the required project permissions:
Steps to add a user to the Jira site-
Navigate to https://admin.atlassian.com
Invite the comment author to the site
Assign the Browse Projects and Add Comment permissions to the user.
Then the issues can be imported following the Import Data via CSV.
Was this helpful?