How to get issue id from the Jira User Interface

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

User needs to get the issue id in an easier way from the User Interface (without executing query in the database) in order to search in the JQL query

Cause

Get the issue id from the database is time-consuming. The fast and alternate way to view the issue id is from the User Interface itself.

Resolution

  1. Go to Issues>Search for issues

  2. Click and open the Issue that you wanted to view the issue id

  3. Mouse-over the Edit button and you can view the issue id at the bottom of browser as shown below:

    (Auto-migrated image: description temporarily unavailable)

For this example the issue id is 15575

The same can also be achieved when hovering over the following buttons: Add Comment, Assign or over the menu entries under the More button.

NOTE: If your browser (e.g. Safari) doesn't have Link Preview enabled, you can make use the following steps:

  • Right click on the Edit, Add Comment, Assign Button or on any of the menu entries under the More button

  • Select Copy Link

  • Use a new tab or any text editor (i.e. TextEdit, Sublime...) and copy the link there.

  • You will see the same link as in the Link Preview with the id listed.

Updated on April 8, 2025

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