How to get accents to work on Rapid Board quick filters
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
When adding a quick filter to the rapid board with status having accents in their names, the accents disappear when using an uppercase letter.
À valider (to validate)
À résoudre (to resolve)
For example, if I set the following jql:
1
status in ("À résoudre")
If you go to the board and go back to the configuration, the text changes to :
1
status in ("A résoudre")
Notice that the "A" doesn't have the accent anymore, but the "é" kept it.
Diagnosis
JIRA is using SQL Server as the database backend.
Cause
The collation type SQL_Latin1_General_CP437_CI_AI does not support accented characters. Due to this, any accented character which is sent to the database gets stored as a non-accented character in the database. The silent conversion happens at the database side and hence we do not see any errors.
Solution
Workaround
As a workaround make manual modifications on the database (only for the QUERY column of "AO_60DB71_QUICKFILTER") and change the collation type to SQL_Latin1_General_CP1_CI_AI:
Before proceeding create a Database Backup.
Step 1:
Shutdown JIRA;
Step 2:
Find the AO_60DB71_QUICKFILTER table and modify the QUERY column;
Step 3:
Note the QUERY column is set to the default database collation click on it to modify;
Step 4:
Change the SQL Collation to SQL_Latin1_General_CP437_CI_AI;
Step 5:
Save the changes and restart JIRA;
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