How to download email processing logs for JSM email handlers

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Jira Service Management Cloud doesn't provide a way to export email processing logs. In some scenarios, it can be necessary to download the logs for record-keeping because logs get vanished when you reconnect the email channel or if you want a JSON file for the same, for such a requirement you can generate the export of email processing logs from your browser by following the instructions on this page.

Environment

Jira Service Management Cloud

Diagnosis

At this moment we can only access the logs on UI as suggested in the article View the email processing and connectivity logs.

Solution

The steps listed below can be used by the project admin as a workaround to generate an export of the logs:

  1. Go to Project Settings > Email request > View logs

  2. Open the network console of your browser

  3. Click on the Refresh button available at top right of the email log window as shown below and copy the Request URL from network tab:

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  4. Paste it into a new tab after changing the limit as per your need

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  5. Copy the result and save it as a JSON file

Updated on April 8, 2025

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