How to deal with Jira issues with large worklog which could cause performance degradation

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Jira issues with large worklog history can impact Jira performance. This KB can help on how to identify those Jira issues and how to fix the large worklog history.

Environment

Jira 8.0 and above

Diagnosis

How to identify Jira issues with large worklog history.

- The query below will return the issueid of records having more than 500 entries

1 select issueid, count(id) from worklog group by issueid having count(id) > 500 order by (count(id)) desc;

- The query below will return the Jira issues having more than 500 entries

1 select concat(p.pkey,'-',i.issuenum) as issue, count(a.id) from worklog a, jiraissue i, project p where i.project = p.id and i.id = a.issueid group by p.pkey,i.issuenum having count(a.id) > 500 order by count (a.id) DESC;

The query is made for Postgres Database and can be adjusted to work for other database providers. Also, we have noticed that records having more than 1000 worklog entries may impact Jira performance

Solution

  • If you have noticed an issue with a lot of worklog entries, that are taking time to load. You may follow the suggestions below to mitigate the issue

    • Clone the issue as the case history is not cloned to the new issue.

    • Either delete or archive the original ones.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.