How to automatically send email notification to assignee if a ticket is not updated for a certain time

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This Knowledge Base document explains how to notify users and send notification emails when an assignee of a particular ticket/issue is not doing/updating any activity in a certain time stamp. This will help ensure that issues are not left unattended for too long and that the appropriate stakeholders are notified when action is needed.

Environment

Jira 8.X & 9.X

Diagnosis

For instance, we want to send a notification email when there has been no update for a specific time for example 2 days. It's also possible to include a custom message alert to notification.

Solution

Create a sample Project Automation by following the below steps:

  1. Go to the project where you want to set up the automation and click on "Project settings" in the bottom left corner.

  2. Click on "Project Automation" in the sidebar on the left-hand side.

  3. Click on "Create rule" in the top right corner.

  4. In the "Trigger" section, select "Scheduled" and set the frequency to "Every 1 day". We can set it according to business requirements

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  5. In the "JQL" field, enter the JQL query according to business requirements.

  6. This JQL query will check if the issue status is not closed and if the issue was last updated more than 2 days ago.

  7. In the "Actions" section, click on "Add action" and select "Send email".

  8. Fill out the email details, including the email subject, recipient as Assignee, and message body.

  9. Click on "Create" to save the automation rule.

Updated on April 8, 2025

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