Global Mail Settings redirect to HTTP Status 405 – Method Not Allowed
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Observed HTTP Status 405 – Method Not Allowed error while accessing Global Mail Settings page navigated from System -> Mail -> Global Mail Settings

Environment
Jira Server / Data Center.
Diagnosis
The initial log analysis shows below the error message in atlassian-jira.log:
1
http-nio-8080-exec-23 WARN XXXX 325x2074x1 xxxxxxx 0:0:0:0:0:0:0:1 /secure/admin/GlobalMailSettings.jspa [c.a.j.web.dispatcher.JiraWebworkActionDispatcher] Action 'com.atlassian.jira.internal.mail.processor.webwork.GlobalMailSettingsAction!renderGlobalMailSettingsPage' does not support 'GET' request method
Cause
This issue is observed when
You have Jira Service Management and Jira Software installed
Later Jira service management is removed/uninstalled and upgrade is performed for Jira Software only.
Post upgrade HTTP Status 405 – Method Not Allowed issue is observed on Global Mail settings page, as this is a feature of Jira Service Management(JSM) and uninstallation of JSM doesn't not completely remove all the jar files related to Jira Service Management.
See more at: Jira Service Management Upgrade Failed With Error "Failed to resolve plugin dependencies within OBR"
Manage global mail settings
There are two global mail settings—email puller and email processor—that are used by Jira Service Management only. They don’t impact any other email settings you have set up for Jira.
To manage global mail settings:
Select Administration > System.
Under Mail, select Global mail settings.
Choose one of the following:
Email puller: connects to your mail servers every minute and pulls the email data into the database. Emails with attachments larger than 25MB are not be pulled.
Email processor: filters the emails (for example, to remove auto-replies and spam) using information stored in the database.
Solution
Solution 1
If there is plan to continue using Jira Service Management. In this case problem will be solved after properly installing JSM.
Solution 2
If there are no plans to continue with Jira Service Management.
Solution 2.1
Disable the jira-email-processor-plugin from the Manage Apps page.
Solution 2.2
Remove the jar file jira-email-processor-plugin-xxx.jar from the directory <Jira_HOME>/plugins/installed-plugins
Stop Jira
Clear your plugin cache. To do this, delete completely the 2 following folders.
⚠️ Not to worry, these 2 folders will be rebuilt when Jira starts:
1 2
<Jira_HOME>/plugins/.osgi-plugins/ <Jira_HOME>/plugins/.bundled-plugins/
Go to the directory <Jira_HOME>/plugins/installed-plugins/ and remove jira-email-processor-plugin-xxx.jar
Start Jira.
Was this helpful?