Fix Slow Jira Cloud Automation Due to Excessive JQL Query Results

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Resolve errors in scheduled automation rules by narrowing JQL query scope for global and project category settings.

Diagnosis

  • Manually running the Automation rule might fail or take longer (~60 seconds) to execute. 

Jira was slow to respond, because the JQL query returned too many issues. Narrow the scope of this JQL query and try again:

resolution = Unresolved AND updated <= -7d AND assignee is not EMPTY AND status = "Backlog"

  • HAR file captured while running the Automation manually will have below 400 errors and "jqlTooComplex" response:

Request URL:https://<URL>/secure/QueryComponent!Jql.jspa Request Method:POST Status Code:400 Remote Address:<IPAddress>
{ "errorMessages": [ "jqlTooComplex" ], "errors": {} }

Cause

  • Try accessing Application link within the site you run into the error "Something went wrong. The server returned a bad response."

  • Verify the invalid or corrupted Application links to Jira application that you might have.

Solution

Remove or re-add the corrupted application link.

Updated on April 30, 2025

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