Fix versions field disappear in the new issue view

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The "fix version" custom field loads and then disappears upon the page load in the New issue view.

Environment

Cloud - New issue view

Steps to reproduce

  1. Add the "Fix Versions" field above the "HIDE WHEN EMPTY" line as a "Context Field" to a project

  2. View an issue that does not have a value for FixVersions.

  3. The Fix Version field would be shown while the page is loading and it would disappear once the page is completely loaded.

  4. If the page is refreshed this pattern would be visible.

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Cause

The user is missing the resolve issue permission.

Solution

  • The ability to update the "Fix Version" is granted by the Resolve Issue permission. However, in the new issue view, this field won't be persisted if the user is not granted this permisison.

  • The field would be persisted if the user is granted the resolve issue permisison.

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Updated on April 8, 2025

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