Fix Jira Cloud due date field showing wrong value after transition

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

Adding a value to the Due date field on a transition screen, appears incorrectly on the issue view.

Diagnosis

Example:

When the date 17/May/2024 is selected from the calendar, the Due date field on the transition screen is updated to May 15, 24, on the issue view.

Where do these properties reside on the Cloud site?

  • Navigate to the Settings icon → General configuration page and click Advanced Settings or

  • Directly open this link: https://<yoursitename>.atlassian.net/secure/admin/AdvancedApplicationProperties.jspa

Cause

There is a mismatch in the jira.date.picker.java.format and jira.date.picker.javascript.format properties.

Solution

Correcting the properties

  • Go to Settings icon → General configuration page and click Advanced Settings or

    Advanced Settings

  • Directly open this link: https://<yoursitename>.atlassian.net/secure/admin/AdvancedApplicationProperties.jspa.

As mentioned indirectly in Changing the Due Date Input Format, ensure that the values of jira.date.picker.java.format property and that of the jira.date.picker.javascript.format property match as per the following table:

Value of the jira.date.picker.java.format property

Value of the jira.date.picker.javascript.format property

dd

%d

MM

%m

yyyy

%Y

MMM

%b

d

%e

yy

%y

MM

%m

Apply the same to the values of jira.date.time.picker.java.format and jira.date.time.picker.javascript.format:

Value of the jira.date.time.picker.java.format property

Value of the jira.date.time.picker.javascript.format property

HH

%H

mm

%M

h:mm a

%l:%M %p

hh:mm a

%I:%M %p

Updated on September 26, 2025

Still need help?

The Atlassian Community is here for you.