How to Fix Epics Not Showing in Jira Epic Panel Due to Wrong Issue Type
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When a user intends to create any Epic in the Epics Panel, the default issue type for the Epics is not Epic issue type (for example bug instead of epic).
Diagnosis
Epics do not show up in the Epic Panel when they are created with an incorrect issue type or when the Epic Status field is misconfigured. Common causes include:
The issue type used is not set to Epic.
The Epic Status field is missing, incorrectly configured, or has the wrong options.
There may be duplicate Epic Status fields or context misalignment due to imports or manual changes. To diagnose, check the issue type of missing Epics, review the Epic Status field configuration, and ensure the correct context and options are set for the Epic issue type
Cause
Per JSWSERVER-6927 - If another Issue type exists with default Epic ID, Greenhopper treats it as the new Epic, this most likely occurs when the user deletes/changes the Jira's default issue types so Jira won't map it correctly to the exact issue type.
Solution
This is a dangerous operation. Be careful to back up your database prior to attempting it.
BACK UP YOUR DATA USING THE INSTRUCTIONS AT Backing Up Data PRIOR TO ATTEMPTING THIS PROCEDURE
Identify the 'Issue Type' IDs for the Issue Types used by Jira with the following SQL.
select id, pname from issuetype where pname in ('Epic');
Epic
Go to Administration > Issues > Issue Types
Click on the 'Edit' link for the following Issue Types and note down the IDs
Epic
For example if the url is
http://servername/secure/admin/EditIssueType!default.jspa?id=6
then the ID is6
.
Run the below SQL in the Jira database to locate the current configuration data:
select propertyvalue from propertytext where id = (select id from propertyentry where property_key ='GreenHopper.Epic.Default.issuetype.id');
The returned text will be a long one and we recommend copying the contents from the displayed output to a text editor of your choice.
Modify the XML output from the previous step (using the text editor) to so that the below entries point to the right custom field ids which we identified in the initial step.
XML Attribute | Related Custom Field | Sample XML |
gh.issue.storypoints | Story Points | <entry> <string>gh.issue.storypoints</string> <string>customfield_10900</string> </entry> |
gh.issue.rankingfield | Ranking (Obsolete) This is from versions of JIRA Agile (now Jira) prior to 6.x. | <entry> <string>gh.issue.rankingfield</string> <string>customfield_10002</string> </entry> |
gh.issue.labelfield | Epic/Theme | <entry> <string>gh.issue.labelfield</string> <string>customfield_10001</string> </entry> |
gh.issue.businessvalues | Business Value | <entry> <string>gh.issue.businessvalues</string> <string>customfield_10004</string> </entry> |
gh.issue.flaggingfield | Flagging | <entry> <string>gh.issue.flaggingfield</string> <string>customfield_10000</string> </entry> |
The XML also includes these additional values for the following 'Issue Types':
XML Attribute | Related Issue Type | Sample XML |
gh.issue.story | Story | <entry> <string>gh.issue.story</string> <string>7</string> </entry> |
gh.issue.task | Technical Task | <entry> <string>gh.issue.task</string> <string>8</string> </entry> |
gh.issue.epic | Epic | <entry> <string>gh.issue.epic</string> <string>6</string> </entry> |
gh.issue.businessvalues | Business Value | <entry> <string>gh.issue.businessvalues</string> <string>customfield_10004</string> </entry> |
Once the XML is prepared, update back the database with the below SQL command:
update propertytext set propertyvalue = <copy the contents from the text editor containing the XML here> where id = (select id from propertyentry where property_key ='GreenHopper.Epic.Default.issuetype.id');
(Optional - Oracle Only): Commit the changes to database by an explicit
COMMIT
.Start Jira.
Reindex Jira and test to see if you can use Jira without errors.
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