Fix Different Issue Status Between Jira View Issue Screen and Issue Navigator

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This problem can be caused in two cases :

Case 1

The Issue Navigator shows a different status in the View Issue screen and the Issue Navigator. The following error might appear in the atlassian-jira.log log:

org.ofbiz.core.entity.GenericEntityException: while inserting:[GenericEntity:ChangeItem][oldvalue,dschofield][group,15659][newvalue,sdabney][field,assignee][oldstring,scho][newstring,Joe Bloggs][id,18232][fieldtype,jira]SQL Exception while executing the following:INSERT INTO changeitem (ID, groupid, FIELDTYPE, FIELD, OLDVALUE, OLDSTRING, NEWVALUE, NEWSTRING) VALUES (?, ?, ?, ?, ?, ?, ?, ?) (Duplicate entry '18232' for key 1)

Case 2

There is a custom transition in your workflow. If you look at the workflow post functions, the re-index is not after the issue update. In this example, the reporter gets changed but the issue does not get re-indexed. See cause 3 below.

Post Functions Jira Server

Solution

Cause

  1. Sometimes the index in JIRA can get out of sync, for example if an Antivirus prevents JIRA from writing to the index. As the index was not updated, the issue was not transitioned properly and this may also occur if JIRA loses its connection with the database.

  2. After 5.1, the indexing of issues during a workflow transition has changed. Please refer to the linked article as the indexing is now suspended during workflow transition.

  3. When the workflow post-function is not configured correctly, then the issue does not get re-indexed at the right time and hence the issue status does not reflect the right information.

Resolution

Cause 1 :

Cause 2 :

  • Check the plugin that is used to perform the transition. Check with the plugin provider and then ask them to provide an updated version of the plugin that fixes this problem.

Cause 3 :

Move the position of the of the re-index post function and set it after issue update. See below screenshot as an example :

Post Functions_2 Jira Server

Updated on June 16, 2025

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