Fix 404 Error When Searching for Request Types in Jira Help Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Searching for a request type in the Help Center of a Service Management Customer Portal doesn't find the request types with the keyword. The F12 Developer tools of the browser shows a 404 response:

F12 Developer tools

Diagnosis

  1. If there're linked Confluence Knowledge Bases, the Confluence pages can still be found with the same keyword normally

  2. From Manage add-ons -> All add-ons, Service Management Search Plugin is Disabled or not all of its modules is enabled

  3. This SQL query:

    select * from pluginstate where pluginkey like '%servicedesk-search%';

    shows that the plugin is Disabled in the database:

pluginkey

pluginenabled

com.atlassian.servicedesk.plugins.servicedesk-search-plugin

false

Cause

Service Management Search Plugin must be enabled with all modules for the search function in Help Center to work properly.

Solution

Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

Enable the plugin by following these steps:

  1. shut down Jira

  2. run this SQL query to enable the plugin in the database:

    DELETE from pluginstate where pluginkey like '%servicedesk-search%';

  3. restart Jira

Updated on June 16, 2025

Still need help?

The Atlassian Community is here for you.