Filter results are empty in dashboard gadget but not in the filter page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

The filter results gadget doesn't show any results whereas the filter page (with the JQL) shows issues as expected.

Diagnosis

Change the JQL of the filter and see if the gadget displays the results correctly.

For instance, if the JQL has a date comparison like CreatedDate > 2018-12-11, remove the clause, save the filter, and refresh the dashboard page.

Cause

The root cause of the problem is still unknown.

This behavior is being investigated and tracked via JRASERVER-71986 - Filter results are empty in dashboard gadget but not in the filter page

Solution

Workaround

  1. Capture the filter results gadget configuration to replicate it.

  2. Delete the gadget from the dashboard.

  3. Add a new filter results gadget with the same configuration.

Updated on April 2, 2025

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