'FileNotFoundException No Segments File Found in org.apache.lucene.store.FSDirectory' Due to Index Directory Corruption
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
No issues are appearing after logging into JIRA. Logs (atlassian-jira.log) contain errors like this one:
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http-8080-Processor17 ERROR [500ErrorPage] Exception caught in 500 page
java.io.FileNotFoundException: no segments* file found in
org.apache.lucene.store.FSDirectory@C:\DATA\JIRA\issues: files:
org.apache.jasper.JasperException: java.io.FileNotFoundException: no segments* file found in
org.apache.lucene.store.FSDirectory@C:\DATA\JIRA\issues: files:
Cause
This can happen if you restore a database backup to a new JIRA system.
Migrate to a different server.
After an upgrade.
Resolution
Configure JIRA to utilize a new Index location under
Administration > Indexing
. If your dashboard does not appear, try pasting the URL directly to the administration page: http://YOUR_SERVER_URL/secure/admin/jira/IndexAdmin.jspaClick Full/Lock
Reindex to rebuild the index
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