Failing to import issues with the error The reporter specified is not a user

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The user is unable to import issues from a CSV file to the Jira instance due to the following error:

1 2022-06-06 18:55:11,692+0000 JiraTaskExecutionThread-9 ERROR 1135x159034x1 1x3lcg2 XXX.XX.XX.XX,XX.XXX.X.XXX /secure/admin/BulkCreateValidationPage%21validate.jspa [c.a.j.p.i.i.bulkcreate.engine.BulkCreateDataImporter$ValidableFileImportLoggerThread[http-nio-8080-exec-2,5,main]] Issue can't be created due to the error/s [ The reporter specified is not a user.; User 'username@domain.com' does not exist. ]

Environment

8.20.1

Cause

Scenario 1: There is a blank space at the beginning/end of the reporter name within the CSV file.

Scenario 1: The reporter name within the CSV file does not match any username registered in Jira.

Solution

Scenario 1:

Review the CSV file and ensure that there are no blank spaces at the beginning/end of the username in the reporter column.

Scenario 2:

Check whether the username in the error message matches any username in the database.

If the users in the database come from an external directory, check the following property in the User Directory configuration in Jira.

1 ldap.user.username: sAMAccountName

If it is configured to use the sAMAccountName, adjust the reporter column in the CSV file to match this format instead of the email address.

Updated on April 24, 2025

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